Get webhook notifications whenever Global Weather and EAS Society creates an incident, updates an incident, resolves an incident or changes a component status.
All services have recovered and are operating at full capacity. This incident has been resolved.
Posted Nov 18, 2025 - 16:14 UTC
Update
Our upstream service provider has indicated that a fix has been applied and this incident is considered resolved. WeatherRadio is still experiencing issues due to the failure of a dependent service. We are continuing to monitor for any regressions on all other services.
Posted Nov 18, 2025 - 15:11 UTC
Update
We are seeing a lowering in the error rate users are experiencing when accessing our services. We will continue to monitor until we see full remediation.
Posted Nov 18, 2025 - 14:59 UTC
Update
We are beginning to see a lowering in the error rate users are experiencing when accessing our services. We will continue to monitor until we see full remediation.
Posted Nov 18, 2025 - 14:35 UTC
Update
We are continuing to work with our upstream service provider on a time-frame for restoration of service.
Posted Nov 18, 2025 - 14:22 UTC
Update
We are including the ERN website in this incident as an affected service.
Posted Nov 18, 2025 - 13:20 UTC
Update
We are seeing a much higher rate of failure on our services. We will continue to provide updates as needed.
Posted Nov 18, 2025 - 13:18 UTC
Update
We are continuing to see an elevated error rate. We will provide updates as we learn more.
Posted Nov 18, 2025 - 12:07 UTC
Monitoring
We are beginning to see a lowering in the error rate users see on our services. We will continue to monitor until we see full remediation.
Posted Nov 18, 2025 - 11:54 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 11:48 UTC
Identified
We have identified an outage of some of our services related to an upstream service provider. We are measuring the impact of this outage now.
Posted Nov 18, 2025 - 11:46 UTC
This incident affected: globaleas.org, gwes-eas.network, Central Alert Repository, and WeatherRadio.