Get webhook notifications whenever Global Weather and EAS Society creates an incident, updates an incident, resolves an incident or changes a component status.
We have migrated back to our production environment, and service restoration is complete.
Users, primarily those who provide streams, may need to flush their DNS cache in order to stream again.
Posted Sep 13, 2026 - 18:05 UTC
Update
Our primary WeatherRadio instance is showing promising signs of recovery. We will be migrating back later tonight.
Users, primarily those who provide streams, may need to flush their DNS cache in order to stream again.
Posted Sep 12, 2026 - 14:23 UTC
Update
Our recovery instance of WeatherRadio has been deployed and is successfully serving traffic.
Until our primary instance comes back online, all new applications for streams will be delayed to prevent data inconcistencies.
Posted Sep 12, 2026 - 04:08 UTC
Monitoring
We are implementing a last-ditch recovery effort while we are awaiting standard service recovery. This is a temporary solution to allow users to use WeatherRadio services while we await proper resolution from our hosting provider.
WeatherRadio may be slow to load, and stream providers may need to flush their DNS cache while we migrate systems over to the temporary runtime environment.
Posted Sep 12, 2026 - 03:52 UTC
Update
We are awaiting restoration of service from an upstream service provider.
Posted Sep 12, 2026 - 03:43 UTC
Update
We are awaiting restoration of service from an upstream service provider.
Posted Sep 12, 2026 - 01:15 UTC
Update
We are awaiting restoration of service from an upstream service provider.
Posted Sep 12, 2026 - 00:32 UTC
Identified
We have identified the issue as a network connectivity problem affecting the server hosting WeatherRadio.
Posted Sep 12, 2026 - 00:15 UTC
Update
WeatherRadio is currently unavailable due to a network connectivity issue affecting its server. We are investigating the issue and working to restore service as quickly as possible.
Posted Sep 11, 2026 - 23:26 UTC
Investigating
We are currently investigating an issue where the WeatherRadio streaming backend service, as well as the webpage, are unavailable.